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 Getting Started with the EPA Metadata Editor Version 4.0 (EME v4.0) 

Who should use EME v4.0? 

EME v4.0 is recommended for non-geospatial metadata creation. EME v4.0 is designed to assist users in the creation 
of metadata that complies with current ISO standards. Individuals who are responsible for creating metadata for non-
geospatial data resources may use EME v4.0 for this purpose. 
  
EME v4.0 is NOT recommended for geospatial metadata creation. EPA is working towards full adoption of ISO 19115 
for geospatial metadata, but does not expect to begin the transition until after ISO 19115-3 (which will contain critical 
geospatial metadata elements not contained in the current standards). ISO 19115-3 is scheduled for release in 2015. 
Until then it is recommended that EME v3.2.1 be used for all geospatial data resources. 
 

 

What’s new in EME v4.0? 
For users already familiar with the EME, these are some of the highlights of version 4.0:  
 

1. Updated user interface 
2. Multiple contacts and distribution elements per record 
3. Inline validation (real-time results in user interface) 
4. Customizable XML tables 
5. Enhanced Help 

 

 
Installing and accessing EME v4.0 
To download EME v4.0, follow the download instructions on the EME 
webpage: https://edg.epa.gov/EME/download.html.  
 
Installation Prerequisite: Microsoft .NET Framework 3.5 
 

 

Accessing the EPA Metadata Editor as a Standalone Tool 
 

If you are using the EME as a standalone application, then go to 
Start->EPA Metadata Editor to open EME.  

  

http://edg.epa.gov/
http://www.fgdc.gov/metadata/geospatial-metadata-standards
https://edg.epa.gov/EME/download.html
http://www.microsoft.com/download/en/details.aspx?id=21
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Once opened, the user interface presents three tabs, each with metadata elements. Elements are populated with text 
supplied either by the underlying EME v4.0 XML database or by the user entering free text. 

 
User Interface Features 

 
Common Features Across Tabs 

1) Inline Validation  

EME version 4.0 was developed to show the minimum required elements needed to pass ISO schema validation, 
EDG validation, and Data.gov's DCAT validation. All required elements can be identified with an exclamation 

point next to the element name . The EDG website will provide the final validation. Note: Users can save 
metadata records with errors (missing required elements) and edit the record at a later time; however, 
metadata records with errors will most likely not pass EDG validation when attempting to publish. 

2) Ordinality  

The distinction between 'mandatory', 'mandatory if applicable', and 'optional' fields as required by Data.gov's 
Project Open Data/DCAT metadata standard is provided through the use of color-coding in the user interface. 

http://edg.epa.gov/
https://edg.epa.gov/metadata/catalog/main/home.page
http://project-open-data.github.io/schema/
http://project-open-data.github.io/schema/
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Yellow fields are considered 'mandatory', green fields are considered 'mandatory if applicable', and blue fields 
are considered 'optional'. Defaults for individual fields may be selected interactively in the user interface using 
buttons or drop-downs. 

3) The 'D' or 'default' button  

The 'D' or 'default' button is located throughout the EME user interface and when 
clicked, automatically populates the default values stored in the EPA Metadata Editor 
template XML files. 

4) Manual Value Override  

Once a record has been populated either by choosing the 'D' button or selecting a Contact using the drop-down 
list, users can manually override the field values by simply clicking in any field and deleting the existing text or 
modifying the existing text. 

5) Multiple Values  

Many sections in ISO Metadata can be repeated if necessary to allow for multiple values. Contact information is 
the most common example. If a section may be repeated, you will see a plus and x icon. Clicking the plus icon 
adds new sections, while the x deletes the current section. Next to these icons are two arrows enclosing a pair of 
numbers - the first number is the index of the currently shown section, while the second is the total number of 
sections. In the example below, the first out of three Resource Owners is selected. The arrows may be used to 
cycle through the individual sections. 

 

6) Minimized Sections  

Many sections in the interface have been minimized to save space. This icon  indicates that a section has 
been minimized. Clicking on the icon will expand the section for editing. 

 

Global Features 

These features can be accessed from the Edit and Tools menus. 

1) 'Open Database'  

This feature allows users to open and edit the template 
content using the new built-in data table editor. 

 

 

 

 

http://edg.epa.gov/
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2) 'Default Output Format'  

This feature allows users to choose between ISO 19115 or ISO 19115-2. ISO 19115-2 extends the existing 
geographic metadata standard by defining the schema required for describing imagery and gridded data and is 
the default. For non-geospatial metadata, it is recommended that ISO 19115 be used. 

 

 

 

 

3) 'Refresh From Database'  

This feature is used to refresh the EME user interface 
defaults after edits have been made to the database. If the 
EME database is opened and edited from the EME user 
interface button, the 'Refresh From Database' option 
should be clicked to make sure that the defaults shown in 
the user interface reflect the newest edits to the database. 

 

4) 'Set Defaults from Template'  

This feature allows a user to set all defaults for the selected 
tab. The editor will prompt the user to ensure that he/she 
would like to overwrite all information in the selected tab 
with default values as stored in the template XML files. 

 

5) 'Clear All Values'  

This feature allows a user to clear all values in the metadata 
record. 

 

Opening, Saving, and Creating a New Record 
 
To Open an existing record, go to File -> Open and navigate to your existing xml metadata record. Once the metadata 
record is open, the user can edit/overwrite any existing elements. 
 
To Create a New Record, go to File -> New. Upon opening EME, the program will default with a blank record.  
 
To Save an existing record, go to File -> Save or File -> Save As.  

http://edg.epa.gov/
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Minimum Required Elements 

Listed below are the minimum required elements to pass ISO validation. To learn more about each element, please see 
the Appendix. For more detailed information about each element, please visit the EME Help. 

 

Description     

  Title   

  Abstract   

Bounding Box     

  Description   

  Coordinates   

Time Periods     

  Temporal Extent of Resource   

    Begin Date 

    End Date 

  Creation Date   

  Publication Date   

  Revision Date   

  Update Frequency   

Distribution Contact     

  Contact   

     Role 

    Individual 

    Organization 

    Position 

  Contact Details   

    Linkage 

    Linkage Type 

  Digital Transfer Options   

    Linkage (only if Digital Transfer Options is included) 

    Function (only if Digital Transfer Options is included) 

  Distribution Format   

    Name (only if Distribution Format is included) 

    Version (only if Distribution Format is included) 

Resource Constraints     

  Security Constraints   

    Use Limitation/Access Level 

    Classification 

Contacts     

  Resource Owner   

    Role 

    Individual 

    Organization 

    Position 

  Contact Details   

http://edg.epa.gov/
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    Linkage 

    Linkage Type 

  Resource Producer   

    Role (Only if Resource Producer is included) 

    Individual (Only if Resource Producer is included) 

    Organization (Only if Resource Producer is included) 

    Position (Only if Resource Producer is included) 

  Contact Details   

    Linkage (Only if Resource Producer is included) 

    Linkage Type (Only if Resource Producer is included) 

   Metadata Author   

    Role 

    Individual 

    Organization 

    Position 

  Contact Details   

    Linkage 

    Linkage Type 

Metadata Information     

  Resource Type   

  Last Modified   

  Metadata Standard   

    Standard Name 

    Standard Version 

 

  

http://edg.epa.gov/
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Setting up the EME Database 
When first installing EME, it can be helpful to set up the EME Database to ensure that the defaults match your 
organization’s specifications.  

Customizing the EME Database 

The EME utilizes data tables stored as Extensible Markup Language (XML) files to supply default information within 

the user interface. By using the provided data table editor, information stored in the XML files can be modified by 

the user to include new data or to change defaults that are used by the 'Set Default' buttons. 

Database Structure 

The database is structured to align closely with the flow of the user interface. Users can edit the following tables: 
Contact_Information, BoundingBox, KeywordsEPA, KeywordsISO, KeywordsUser, and KeywordsPlace. 
 
Each table has a column in it called 'default'. This column controls what is selected in the EME when the user clicks 
on the 'Set Default' or 'D' buttons. 

Editing the Database 

The following example outlines how to add an additional contact to the Contact_Information table, however, the 
user can follow the same guidelines when editing the BoundingBox, KeywordsEPA, KeywordsISO, KeywordsUser, and 
KeywordsPlace tables. 

To add an additional contact to the preconfigured contact table: 

1) Navigate to Tools --> Open Database.  

 

2) Select the table of interest, e.g. Contact_Information, BoundingBox, KeywordsEPA, KeywordsISO, 
KeywordsUser, or KeywordsPlace. 

3) Click on the Enable Edit Mode button (the table will turn pink when in edit mode) 

http://edg.epa.gov/
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4) Scroll to the bottom of the table and enter the contact information. 
5) After adding a new contact, click on the End Edit Mode button (the table will turn back to green) and close 

the table. 
6) The newly added contact should now display at the bottom of the list after clicking on the drop-down arrow 

in the Select Contact box. 

To set the Default contact: 

Setting a default contact allows the user to click on the "D"; button to autopopulate 
the fields with the default contact information found in the "Contact_Information" 
table.  
 

1) Scroll to the far right of the table and click on the default checkbox next to the default contact record. Note 
that you will need to uncheck the currently selected default when selecting a new default. If you have more 
than one default selected, the record furthest down in the table will be used. In the next release we hope to 
allow you to cycle through multiple defaults by repeatedly clicking the "D" button. 

2) After setting the default contact, click on the End Edit Mode button (the table will turn back to green) and 
close the table. 

3) Choose Tools > 'Refresh From Database' to update 
the user interface. You will need to Refresh From 
Database for each tab where changes should be 
reflected. 
 

Special Data Table Customizations 

The EME provides a user interface for editing commonly accessed data tables. The EMEdb folder also stores a 
template metadata record used for populating additional default content 
(ISO19115MD_GenericMetadataTemplate.xml). Changes to these XML files can easily be shared with users. 
Other XML files found within the EMEdb folder should not be modified. Changes to those files could cause 
stability issues with the application.  
 

 

http://edg.epa.gov/
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Data table storage location:  
 
The XML data tables are stored in two places on a user's computer. During installation, back-up copies are 
placed in the application installation directory on your machine (usually, C:\Program Files (x86)\Innovate! 
Inc\EPA Metadata Editor v4.0\Eme4xSystemFiles\EMEdb). The EME also creates an editable copy of the XML 
data tables in each user's application data folder (e.g., "C:\Users\USERNAME\AppData\Roaming\Innovate! 
Inc\EPA Metadata Edtior 4x\Eme4xSystemFiles\EMEdb). EME makes this copy so that the operational data are 
not write-protected.  
 
When EME starts, it looks for the data tables in the following locations:  

 Check and use if the EMEdb folder exists in users own area  
 Otherwise make a copy the EMEdb folder from the installation directory into the user's own area.  

Changes made to the XML files located in the user's application data folder will only be seen by that user. The 

user can revert back to the originally installed data tables by closing the EME application and deleting the 

EMEdb folder located in their user directory. The next time EME is launched, a copy the EMEdb folder from the 

installation directory will be placed into the user's own area.  

 

Understanding this behavior will also assist in sharing data table customizations with other uses. To share on a 

user-by-user basis a person can copy their EMEdb folder (located in their application data folder) to the 

intended user's application data folder. Alternatively, if advanced users wish to make system-wide changes and 

override the original data, the folder could be copied into the application installation directory and subsequently 

deleting the EMEdb folder in each existing user's application data folder. Best Practice: It is recommended that 

the user create a back-up of the original EMEdb folder before making system-wide changes.  

 

Modifying the default metadata template: 

 

Users can auto-populate an empty metadata record using 

values stored in a template record by clicking the "Set 

Defaults From Template" button under the Edit menu item. 

The template record is located in the EMEdb folder and 

named "ISO19115MD_GenericMetadataTemplate.xml".  

 

To modify the template, open the EME Metadata Editor. By default the user interface is blank. Click "Set 

Defaults From Template" to populate the form and then make desired changes. Then, to save changes back to 

the template, click Save and navigate to the template record in the user's application data folder (e.g., 

"C:\Users\USERNAME\AppData\Roaming\Innovate! Inc\EPA Metadata Editor 4x\Eme4xSystemFiles\EMEdb 

ISO19115MD_GenericMetadataTemplate.xml"). Sharing this template is accomplished in the same manner as 

outlined above in the "Data table storage location" section.  

  

http://edg.epa.gov/
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Appendix 
Element Description Example or Best Practice 

Abstract 

This element is required for EPA data 
resources. Typically, this element should 
be used to provide a brief summary of 
the resource. Some of the recommended 
items that should be included in this field 
are: general content and features, 
dataset form (GIS, CAD, image, Dbase, 
etc.), geographic coverage (county/city 
name), time period of content (begin and 
end date or single date), and special data 
characteristics or limitations 

"A total of 54 GPS points were collected 
around the Willamette Valley, Oregon, in 
the fall of 1997 and spring of 1998. 
Locations were selected at road crossings 
over streams and along the Mainstem 
Willamette. Attention was paid to 
achieving relatively even spacing around 
the basin, including farthest extents, and 
along the Mainstem. Points were 
differentially corrected and imported 
into a file geodatabase, attributed to 
indicate location, road, stream, and 
notes." 

Begin Date (Temporal 
Extent of Resource) 

Begin date of the data content Use date-picker 

Classification 
Name of the handling restrictions on the 
resource or the metadata 

Use pick-list 

Coordinates (Bounding Box) 

These elements include the North, South, 
East, and West bounding coordinates of 
the data resource, expressed in latitude 
in decimal degrees referenced to WGS 
84. The recommended way to populate 
these elements is to select a choice from 
the quick pick list next to the default 
button. If you populate these values 
manually, it is recommended that a 
Bounding Box Description be included 
with the Bounding Box coordinates. 

For North and South bounding 
coordinates: -90.0 <= Bounding 
Coordinate <= 90.0 and for East and West 
bounding coordinates: -180.0 <= East 
Bounding Coordinate <= 180.0,  

Creation Date 
Date the resource was brought into 
existence. 

Use date-picker 

End Date (Temporal Extent 
of Resource) 

End date of the data content Use date-picker 

Individual The name of the responsible individual "John Smith" 

Last Modified 
Date of the metadata creation or the last 
metadata update 

Use date-picker 

Linkage (Digital Transfer 
Options - Online Resource) 

URL for any information about where the 
resource can be obtained. 

  

Linkage (Distribution 
Contact Details) 

URL for any information about the 
resource distribution 

  

Linkage (Resource Owner, 
Resource Producer, 
Metadata Author) 

URL for any information about the 
resource owner, resource producer, or 
metadata author 

  

http://edg.epa.gov/
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Linkage Type 
Type of URL provided (download, 
information, offline access, order, search) 

  

Name (Distribution Format) Name of the data transfer format "ASCII" 

Organization Name of the responsible organization 

"U.S. Environmental Protection Agency, 
Office of Environmental Information, 
Office of Information Analysis and 
Access, Information Access Division" 

Position Position of the responsible person. "SEGS Manager" 

Publication Date 
Date when the data resource was 
published or otherwise made available 
for release. 

Use date-picker 

Resource Type 
The class of information to which the 
referencing entity applies 

EME version 4.0 will primarily be used for 
"non-geographic datasets"; however, 
"datasets" may also be selected for any 
data resources with a spatial component. 

Revision Date 
Most recent date on which the data 
resource was changed, updated, or 
modified. 

Use date-picker 

Role 
The role of the distribution contact, 
resource owner, resource producer, or 
metadata author 

Use pick-list 

Standard Name (Metadata 
Standard) 

The name of the metadata 
standard/profile use 

"ISO 19115-2 Geographic Information - 
Metadata - Part 2: Extensions for Imagery 
and Gridded Data" 

Standard Version (Metadata 
Standard) 

The version of the metadata 
standard/profile used 

ISO 19115-2:2009 (E) 

Title 

The title should fully describe the 
resource in a way that distinguishes it 
from other, similar resources, while also 
staying as concise as possible. To this 
end, EPA recommends the following 
template: {Subject, Geographic Extent, 
Relevant Time Period, Data 
Owner/Provider, Office/Region/Research 
Lab of Data Owner} 

Toxics Release Inventory (TRI) Locations, 
Oklahoma, 2012, EPA OIAA, EPA REG 66 
WQPD 

Update Frequency 

The frequency with which changes and 
additions are made to the data resource 
after the initial data resource is 
completed. 

Use pick-list 

http://edg.epa.gov/
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Use Limitation/Access Level 

Degree to which this resource could be 
made available to the public, regardless 
of whether it is currently available to the 
public. 

Use pick-list 

Version (Distribution 
Format) 

Version of the format (date, number, etc)   

 

http://edg.epa.gov/

